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About "StitchBuddy"
Introducing embroidery on Macs for hobbyists.

Viewing embroideries
View embroidery designs and use view options,
copy, print and preview color changes.

Modifying embroideries
Move, delete, rotate and flip parts of embroidery
designs, resize stitches, center a design and add
a basting.

Purchasing "StitchBuddy"
Purchase StitchBuddy via PayPal.

FEATURED TOPICS

Change thread colors
Enter dimensions
Select stitches
Modify selected stitches
Combine multiple designs
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Obtain and enter a license code
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About "StitchBuddy"

StitchBuddy is a hobby-oriented application to view and modify embroidery designs
directly on your Macintosh.

Do you own an embroidery machine and a Mac? Maybe you want to modify your
embroideries, rotate or flip them, rearrange or delete parts, test different colors, or
combine designs? StitchBuddy provides some important features for embroidery hobbyists:

You can open multiple embroidery files to get a preview of the design, to zoom it or
change thread colors to get an impression before actually stitching the design.

There are a lot of options to modify designs. They can be printed using various options
or copied to the clipboard and you can use their image or description in other
applications.

Writing is supported for some design types to save your modifications or simply convert
embroideries from one format into the other. In addition you can export designs to
removable media like USB sticks or flash cards.

In StitchBuddy's preferences you can activate a weekly check for updates, change several
options, and disable / enable warnings dialoges.

StitchBuddy includes a Quick Look (StitchBuddy-QL) and Spotlight plugin (StitchBuddy-
MD), which are installed automatically. With these plugins you can search for
embroideries based on their properties like size, number of stitches, and colors, and
preview them directly in the Finder.

StitchBuddy can be tested with all functions with a limitation of 50 program launches. If
you want to use StitchBuddy after the evaluation, please register your copy and purchase a
license code via PayPal.

Related Topics
Change thread colors

Enter dimensions

Select stitches

Modify selected stitches

Combine multiple designs

Export to USB

Obtain and enter a license code
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Viewing embroideries

StitchBuddy can open several types of embroidery designs, currently Janome JEF and SEW,
Brother PES amd PEC, Melco EXP, Tajima DST and Pfaff VP3, KSM, PCS, PCQ (binary) and
PCD files. After opening a file you see a preview of the design, the used thread colors and
some additional information: the file format and its version, the size of the embroidery,
the hoop size (only JEF, VP3 and PCS), the number of stitches and jump stitches, and the
number of color changes and different colors.

Multiple documents can be opened simultanously and you can use the "Window" menu to
navigate through them. With the "View" menu you can enable or disable 3D effects, show
the design's underlay, jumps stitches, the first and last stitch or select the rulers and a grid
to be displayed.

StitchBuddy is not able to write to all file formats so changes have to be discarded unless
you save the embroidery into an exportable format. The following actions can be
performed after opening an embroidery file.

View Options: The preview of an embroidery is scaled to show the complete design.
You can zoom in/out or reset the original scaling by using the "View" menu, the
corresponding toolbar icons or enter the zoom factor directly in the toolbar.

In addition you can enable / disable several tools: It is possible to show or hide jump
stitches, and the first / last stitch of a design. The center of a design can be indicated by
crosshairs, the stitch area of the current hoop, a grid and rulers can be displayed. You
can deactivate the 3D effect and in the underlay view the line width is reduced to show
underlying stitches.

To measure a distance in the design you can switch the "Mode" toolbar icon into the
measure mode or select the menu item "Design" > "Measure". Then you can click and
drag the mouse to measure a distance. To deactivates the measurement mode, click the
toolbar button or select the menu item again.

Changing colors: Colors of threads can be changed by clicking the corresponding
buttons on the right side. The Mac OS X color selector is shown and you can choose a
color in different ways. Several color lists are provided with StitchBuddy, e. g. Madeira
Rayon or Sulky. For more information, please refer to this chapter.

Clipboard support: You can copy a design into the clipboard to use it in other
applications. The design can be pasted as an image (TIFF) or as a textual description,
depending on the target application. It is also possible to drag and drop a design to
another application. This way the design's image (TIFF) or its description is pasted, or a
JPEG file is created, e. g. in the Finder.

Stitch Simulator: This "Virtual Embroidery Machine" gives you a perfect impression how
a design will stitch out in reality: The stitching process is draw step by step, showing
underlays, jumps, the color sequence, and all details. You can abort or pause a stitch-
out, adjust its speed, jump to any position, and mute the sound played during the
animation. StitchBuddy stays completely operational, so you can change zoom levels,
view options, even select stitches. This function is extremely helpful while examining
designs before stitching.
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■ Printing: Embroidery designs can be printed including their properties and thread
colors. In the printing dialog you can select which view options should be used for
printing, too. In addition it is possible to select a template mode to print the design in
its actual size without detailled information. This option is helpful to position the design
on your sewing project.

Related Topics
Change thread colors
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Modifying embroideries

You can modify embroideries in several ways: Selected stitches can be deleted, copied,
repositioned, rotated, resized and flipped. Stitches can be inserted from the clipboard. In
addtion it is possible to change single thread colors or the whole thread chart. While all
these changes are available to preview their effect, saving modifications is only supported
for some file formats, currently Janome JEF, Brother PES and PEC, Melco EXP, Tajima DST,
and Pfaff PCS. So be sure to save a design into an appropriate format before performing
permanent changes. Of course you can use StitchBuddy to simply convert between file
formats, i. e. save a PES file to use it on a Janome embroidery machine.

Deleting: To delete selected stitches, select the menu item "Edit" > "Delete" or use the
corresponding tool bar icon.

Copy / Paste: To copy or cut selected stitches into the clipboard, just use the menu
item "Edit" > "Copy" resp. "Cut". Stitches can be inserted from the clipboard using the
menu item "Edit" > "Paste". The section will be inserted with a slightly offset and already
selected to support additional modifications more easily.

Move: To move a selected part of the design click on the selection and drag the mouse.
Release the mouse button at the final position. Alternatively use the arrow keys (cursor
keys) to reposition selected stitches by 0.1 mm. Longer or shorter distances can be
entered in a dialog, which will be presented after selecting the menu item "Design" >
"Move Selection..." or click the corresponding toolbar item.

Rotate: To rotate selected stitches by 45 degrees around the center of the selection, use
the menu item "Design" > "Rotate Selection" > "45° Left" / "45° Right" or click the
corresponding toolbar items. To rotate a selection by a variable angle clockwise or
counter-clockwise, use the menu item "Design" > "Rotate Selection" > "Variable...".

Resize: To change the size of selected stitches, use the menu item "Design" > "Resize
Selection..." or click the corresponding toolbar item. StitchBuddy does not change the
stitch count when resizing a selection. Making a selection too small might result in a
design too dense and might even cause needle breaks. On the other hand making a
selection to large might result in a loose design with holes. Therefor the resizing is
limited to +/- 15% and it is not recommended to make larger adjustments.

Flipping (Mirror): To flip selected stitches left-to-right or upside-down, just select the
menu item "Design" > "Flip Selection" > "Left/Right" or "Up/Down" or use the
corresponding tool bar icons.

Center: To center a design, just select the menu item "Design" > "Center" or use the
corresponding tool bar icon. A variable number of jump stitches is inserted to center the
design inside its hoop.

Baste: To add basting stitches, just select the menu item "Design" > "Add Basting...".
You can specify the distance to the design and the stitch length. Afterwards a rectangle
is stitched in black before starting the design to attach a stabilizer or check the design's
alignment. A basting can easily deleted after selecting it with the "section" mode.

Changing palettes: A design has an assigned color palette from which all thread colors
are taken. By default this is the internal palette of an embroidery file. You can assign a



■

■

different color palette and StitchBuddy will map all internal colors to the most similar
ones automatically. For more information, please refer to this chapter.

Changing colors: Colors of threads can be changed by clicking the corresponding
buttons on the right side. The Mac OS X color selector is shown and you can choose a
color in different ways. However you pick a color, the most similar one of the design's
current palette will be used automatically. For more information, please refer to this
chapter.

Converting: StitchBuddy is able to export some file formats (currently JEF, PES, PEC, EXP,
DST and PCS). Of course this feature can be used to save modifications, like color
changes, rotations or flipping. Additional you can use this function to convert
emboideries between different formats. StitchBuddy will perform some tasks to ensure a
proper conversion: Internal colors are adjusted because a different palette has to be
used (JEF and PES/PEC only), and stitches may be splitted to meet limitations of the
target file type.

All modifications performed after saving the design can be undone.

Always check the hoop size and position of a design before actually stitching it!
StitchBuddy will remind you when saving a file, but this dialog can be dismissed for the
future. To reactivate the warnings check the corresponding option in StitchBuddy's
preferences.

Always make backups before modifying embroidery files!

Related Topics

Change thread colors

Enter dimensions

Select stitches

Modify selected stitches

Combine multiple designs

help:anchor=stb2001%20bookID='StitchBuddy%20Help'
help:anchor=stb2001%20bookID='StitchBuddy%20Help'
help:anchor='stb2001'%20bookID='StitchBuddy%20Help'
help:anchor='stb2007'%20bookID='StitchBuddy%20Help'
help:anchor='stb2002'%20bookID='StitchBuddy%20Help'
help:anchor='stb2003'%20bookID='StitchBuddy%20Help'
help:anchor='stb2004'%20bookID='StitchBuddy%20Help'


Purchasing "StitchBuddy"

The trial version of StitchBuddy can be tested with all functions, but expires after 50
application launches.

If you want to use StitchBuddy after the evaluation, please purchase an individual license.
With this license you can use StitchBuddy on one or more computers, but you are not
allowed to share the license code or a registered version of StitchBuddy with other users.

Related Topics
Obtain and enter a license code
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Change thread colors

Each design type (except Melco EXP, Tajima DST or Pfaff KSM) has its own internal palette
of thread colors, e. g. JEF uses Janome thread colors. To support other thread cards
StitchBuddy can save extended color information for every embroidery in a separate file
with the extension ".threads". With these files even Melco EXP, Tajima DST or Pfaff KSM
designs can be colorized and even better: Both StitchBuddy plugins handle these thread
files to preview embroideries properly or use their meta data.

You can change the whole palette of a design or individual thread colors. StitchBuddy will
choose the most similar color of the current palette automatically. It is even possible to set
a default color palette in StitchBuddy's preferences, and every design without a specific
thread card will be converted automatically when being opened. When saving a design in a
different format StitchBuddy maps to the most similar internal colors, but if a thread file is
used the preview will remain unchanged.

To change a thread palette / a thread color:

Change the design's color palette with the menu item "Design" > "Thread File".
By default StitchBuddy will adjust every new color to match the current palette.

If you don't want this color matching, select "Individual Colors" and every color
stays exactly as selected. A ".thread" file will be written at the same location
when saving the design. Because individual colors lack a specific name, only
their RGB values will be shown.

Choose "Discard Thread File" to use original colors of a design: The internal
color palette (JEF, PES, PEC), RGB colors (VP3, PCS) or no colors at all (EXP, DST,
KSM). The current ".thread" file which holds extended color information is
deleted when saving the design. As this action effects other embroideries with
the same name (there's only only one ".threads" file for all these designs) a
confirmation is required, which can be dismissed for the future. To reactivate
the warnings check the corresponding option in StitchBuddy's preferences.

Select any other menu item and selected colors will be adjusted to the most
similars of the given palette. A ".thread" file will be written at the same location
when saving the design.

To change a single thread color, you can simply click in a corresponding area of
the design. All other colors will be displayed in grayscales and a color picker is
shown for the selected color ("Enhanced Color Selection"). You can achieve the
same efect by clicking on a color name in the thread list. Revert the display to
show all colors by clicking again on the selected color / color name or an empty
part of the design. This enhanced color selection can be disabled in the
preferences, leaving the color box the only possibility to activate a color picker.

The color picker of Mac OS X provides several ways to choose a new color: With
the color wheel you can click directly on the desired color, on the RGB panel you



can specify the red/green/blue values of a color, or you can use color lists to
pick from. Some major color lists of embroidery threads are provided with
StitchBuddy, but please be aware that the displayed color of a thread may vary
between different applications and nature. These color lists support searching
and it is even possible to create your own list with your favourite colors. The
most convenient way is to use the same color list as the design's palette, but
that's not mandatory.

To change another color it is not required to close the color picker: You can just
click on the next color well, a color name or a corresponding part of the design
to select the next color

All color changes can be undone / redone using the menu item "Edit" > "Undo thread file
change" / "Redo thread file change" or "Undo color change" / "Redo color change". All
modifications (even the creation or deletion of ".thread" files) will become permanent when
the design is saved.

Related Topics

Viewing embroideries

Modifying embroideries
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Enter dimensions

StichBuddy can display all dimensions in different measurement units: In millimeters with
one decimal, in inches with two decimals, or in inches with fractions of 32. You can select
the default measurement units you want StitchBuddy to use in the general section of its
preferences, and it's independent of the regional settings in Mac OS X's preferences.

In addition you can enter values in millimeters or inches, decimals or fractions, in any
combination, just as you like:

Sometimes you are asked for dimensions, e. g. when moving a selection or adding a
basting. You can specify the measurement units your input refers to by adding the
appropriate abbreviation. If you don't specify it explicitly the default units are taken from
StitchBuddy's preferences. Even further: if you like to use fractions instead of decimals you
can enter these as well, despite your default selection in the preferences.

Some examples:

To enter one and a half inch with fractions even if the preferences are set to
millimeters (you can also use "inch", "in.", "in" or even a quotation mark as an
abbreviation for "inches"):

"1 1/2 inches"

To enter the same value with decimals (the decimal separator might vary
according to your regional settings in Mac OS X).

"1.5 inches"

To enter the same value using the metric system with millimeters (you can omit
"mm" if StitchBuddy's preferences are set to millimeters):

"38.1 mm"

Although completely unusual you can mix metric units with fractions (you are
not limited to fractions of 32):

"38 1/10 mm"

Remember: all these input options are independent of the default measurement units you
have selected in StitchBuddy's preferences. This is only taken into account if you don't
specify a unit, and of course to display the output of dimensions, and adjust the rulers and
the grid.



Select stitches

To modify an embroidery design it is necessary to select stitches, first. StitchBuddy
provides three different modes how stitches can be selected. You can activate and
deactivate these modes using the corresponding "Edit" menu items or toolbar icons.
Selected stitches are highlighted in red, while unselected ones are grayscaled.

Selection modes:

Rectangle: In this mode click and drag the mouse to draw a rubber band around
a part of the design. Stitches with their start and end point inside this rectangle
are selected.

Section: In this mode all stitches between two color changes or jump stitches
are selected. This makes it easy to select an isolated part of the design.
Attention: It is possible that additional stitches lay under this part and are not
selected. For this reason the underlay view is recommended to select stitches.

Stitch: In this mode you can select single stitches.

To select multiple parts of a design, press the command key ("Apple" key) when selecting
additional parts. To deselect stitches press the shift key while selecting the appropriate
part. A click in an empty area of the design deselects all stitches.

It is easy to change the selection of all stitches using the menu items "Edit" > "Invert
Selection", "Select All" and "Deselect".

Related Topics

Modify selected stitches

Combine multiple designs
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Modify selected stitches

After you have selected a part of a design, several operations can be performed to modify
these stitches.

Modify designs:

Select all stitches you would like to modify. Take care of jump stitches and
underlaying stitches. It is recommend to active the underlay view to select
stitches: "View" > "Display Mode" > "Underlay".

Modify the selected part of the design. Details of all possible modifications can
be found in this chapter.

Make a new selection or proceed with the next modification.

You can undo all modifications made after the last saving of the embroidery file: "Edit" >
"Undo...".

Related Topics

Modifying embroideries

Select stitches

Combine multiple designs
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Combine multiple designs

Selected stitches can be copied into the clipboard and pasted into the same or another
design. This feature can be used to combine multiple designs.

To combine two designs:

Open the first file, select all stitches or a part of the design and use the menu
item "Edit" > "Copy" to copy the selection into the clipboard.

Open the second file and paste the stitches with the menu item "Edit" > "Paste".
All stitches will be inserted with a slightly offset and are automatically selected.
This makes it easy to change their position after the insert operation. If some
stitches of the design were previously selected, they will be deselected. Inserted
stitches and their threads are placed at the end of the design.

Save the modified embroidery, it is suggested to use a different file name.

Insert operations can be undone using the appropriate "Edit" menu item.

Related Topics

Select stitches
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Export to USB

StichBuddy can only read and write embroidery files on volumes, which are directly
accessible for Mac OS X, e. g. USB pen drives. If your embroidery machine requires special
devices or floppy disks, you have to rely on 3rd party applications or drivers, often
available for MS Windows, only.

But even with a normal USB device it is sometimes difficult to save a design in a proper way
to have it recognised by your embroidery machine. StitchBuddy supports you with some
guidance:

The file system, stitch count and file format is checked, and you are navigated to the right
location on the USB device. Currently this assistance is limited to Janome embroidery
machines. After the export hidden system files are optionally removed, as they might
cause problems with some embroidery machines.

Export a design to an USB device:

Select the menu item "File" > "Export..." and select your embroidery machine
(select "Others" for a machine type not listed). Some requirements of your
embroidery machine are shown: Maximum stitch count, supported file formats,
the base folder, if subfolders are supported and the maximum number of files
per folder.

Plug in the USB device and select the target volume. If hidden system files
should be removed after the export and the volume should be ejected, check the
corresponding option. Click on "Continue".

You are naviated to a default folder supported by your embroidery machine.

Based on its type you are allowed to create new folders or enter different file
extensions (to choose different file formats). But it is only possible to navigate to
folders or use extensions supported by your machine. Otherwise the items are
deactivated or it is not possible to confirm the export.

After the export a dialog informs you about the deletion of system files and if
the USB device can be unplugged. An ejected device has to be unplugged and
reconnected to show up in the Finder again, which recreates the hidden system
files.

It is recommended to format USB devices with your embroidery machine, to ensure its file
system and folder structure is supported. Devices larger than 2 GB are reported to work
not at all or only with poor performance.



Obtain and enter a license code

You can test StitchBuddy and all its functions without a registration, but this trial is limited
to fifty application launches. I spent a lot of time and efforts to build this application and
while the Quicklook and Spotlight plugins will remain free, the usage of StitchBuddy
requires a license after the evaluation.

If you find StitchBuddy helpful, please purchase a personal license code and support its
development. With this license you can use StitchBuddy on one or more computers, but
you are not allowed to share the license code or a registered version of StitchBuddy with
other users.

To register StitchBuddy:

Select the menu item "StitchBuddy" > "Purchase" or click on the "Purchase"
button of the reminder at program start. Your web browser is directed to a
corresponding PayPal page and you can easily obtain a single-user license.

You can purchase a license without using StitchBuddy by simply sending the
license fee via PayPal to register@stitchbuddy.de.

After receiving your payment I will send you an email with your registration
name and license key. Please keep this mail as you might need it in the future, e.
g. after installing StitchBuddy on a different computer. Select the menu item
"StitchBuddy" > "Preferences" > "License" or use the registration reminder when
starting the application to enter the registration name and the received license
code.

If you do not want to purchase via PayPal, just sent an email to info@stitchbuddy.de and I
am sure we will find a solution.

Thank you for purchasing StitchBuddy and supporting its development and future
enhancements!
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